Konsensüs Hatası Ethereum Zincirinin Bölünmesine Neden Oluyor

Ethereum ağ istemcisi Geth’in eski sürümünü etkileyen bir hata, düğümlerin ana ağdan ayrılmasına neden oluyor. Hatanın, işlem yapan kullanıcılar için çift harcama saldırılarına ve kayıplara yol açma tehlikesi vardır.

Geth sürüm v1.10.8.’de hata düzeltilmiş olsa da, birçok düğümün eski, yama uygulanmamış sürümleri çalıştırdığı düşünülüyor. 

Tim Beiko, Ethereum nin bir parçası “AllCoreDevs,” önerdi Flexpool, BTC.com ve bu Binance en havuzları Geth eski sürümünde madencilik olmuştu.

Konsensüs hatası, Polygon, Binance Smart Chain, xDAI ve diğerleri dahil olmak üzere Ethereum dışındaki zincirleri de etkiler. Hatanın hem Ethereum hem de Binance Smart Chain’de zaten kullanılmış olabileceğine dair söylentiler Twitter’da dolaşıyor.

Poligon tweeted Kendi ağındaki en doğrulayıcılar zaten en son Geth/Bor sürümüne güncellendi bildirildi.

Neyse ki, Ethereum madencilerinin çoğu Geth istemcisinin güncellenmiş sürümünü çalıştırıyor, bu da hardfork riski olmadığı anlamına geliyor. Geth’in eski sürümlerini çalıştıran madencilik dışı düğümlerle ilgili olarak, ana ağa erişmeleri etkin bir şekilde engellenir.

Önlem olarak, kripto topluluğu üyeleri, kullanıcılara sorun çözülene ve düğümlerin çoğu Geth yazılımının en son sürümüne güncellenene kadar Ethereum ve diğer zincirlerde önemli işlemler yapmamalarını tavsiye etti. DeFi geliştiricisi Andre Cronje, “En son geth’e gönderdiğinizden emin değilseniz, onaylanana kadar bir süre txs yapmaktan uzak durun,” diye yazdı. “Dışarıda yürüyüşe çık, hepimizin buna ihtiyacı var.”